GLIBC error

Installing SecAst, prerequisites, basic configuration, and troubleshooting performance and technical issues. As well, upgrades to SecAst and any underlying software.
Post Reply
User avatar
CRM User
Posts: 172
Joined: Sun Nov 27, 2016 3:41 pm

GLIBC error

Post by CRM User » Sun Nov 27, 2016 6:02 pm

When I start SecAst I see this error:

./secast: /lib64/libc.so.X: version `GLIBC_X.XX' not found (required by ./secast)

What is wrong?
Account for questions transferred from CRM system
User avatar
Telium Support
Posts: 227
Joined: Sun Nov 27, 2016 3:27 pm

Re: GLIBC error

Post by Telium Support » Sun Nov 27, 2016 6:46 pm

The wrong SecAst package has been installed. SecAst is looking for libraries that are more modern (recent) than those offered by your Linux distribution.

If you are sure you downloaded the right SecAst package then try a system wide update using your package manager (eg: “yum update”). Otherwise, return to the Telium web site and download a more suitable SecAst package.

If you don’t see a SecAst package that exactly matches your Linux distribution, try downloading the package for the oldest Linux distribution. The
LTS (Long Term Support) versions of Red Hat (eg: v6) and Ubuntu (eg: v12) are usually the best packages to try.
Post Reply